# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^ (\w*?): ((Number|String|Object|Array),?\n)/ $1: {\n type: $3,\n required: true\n },\n\n/gm;t' <<< "
props: {
book: Object,
progress: Object,
tableData: Array,
},"