re = /^ (\w*?): ((Number|String|Object|Array),?\n)/m
str = '
props: {
book: Object,
progress: Object,
tableData: Array,
},'
subst = ' $1: {\\n type: $3,\\n required: true\\n },\\n\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result