package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) ?(Optional)? ?(ByVal|ByRef)? (\w*)(\(\))?(?:(?: As )(\w*))?(?: = )?(["]\w*["])?`)
var str = `ByRef wbkRef() As Object, Optional ByVal strTetx As String = "text",Optional ByVal something `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}