using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"B\d{3}";
string input = @"Brought my Sony A5000 for my trip
the Airbus A220v300's bathroom has a window
My favorite jet is the B737-900ER flew it like x 239
all stan the queen B747, 120% the B333st
I like the chonky A380
but I love the A350";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}