#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)IO::Memory(O|I)Channel(|32)([\s]|::|&[\s])"
Local $sString = " GS::MemoryOChannel32 oBuffer (IO::MemoryOChannel32::BMAllocation);" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" BinIProtocol.hpp" & @CRLF & _
" BinOProtocol.hpp" & @CRLF & _
" InputBuffer.hpp" & @CRLF & _
" OutputBuffer.hpp" & @CRLF & _
" IChannelAdapter.hpp" & @CRLF & _
" OChannelAdapter.hpp" & @CRLF & _
" MemoryIChannel.hpp" & @CRLF & _
" MemoryIChannel32.hpp" & @CRLF & _
" MemoryOChannel.hpp" & @CRLF & _
" MemoryOChannel32.hpp"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")