// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[x0100:xFFFF]").unwrap();
let string = "Fazıl Say - 2008 - 1001 Nights In The Harem\\01 01. Allegro [Violin Concerto ('1001' Nights in the Harem) - live.mp3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}