using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?><div(?=(?:[^>""']|""[^""]*""|'[^']*')*?\sid\s*=\s*(?:(['""])\s*page(?:(?!\1)[\S\s])*\1))\s+(?:""[\S\s]*?""|'[\S\s]*?'|(?:(?!\/>)[^>])?)+>)\s*[\S\s]{0,5}\s*<\/div\s*>";
string input = @"
<div id=""page126-div"" style=""position:relative;width:918px;height:1188px;"">
</div>
<div id=""page127-div"" style=""position:relative;width:918px;height:1188px;"">
sometext for example
</div>
<div id=""page128-div"" style=""position:relative;width:918px;height:1188px;"">
</div>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}