import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?><div(?=(?:[^>\"']|\"[^\"]*\"|'[^']*')*?\\sid\\s*=\\s*(?:(['\"])\\s*page(?:(?!\\1)[\\S\\s])*\\1))\\s+(?:\"[\\S\\s]*?\"|'[\\S\\s]*?'|(?:(?!\\/>)[^>])?)+>)\\s*[\\S\\s]{0,5}\\s*<\\/div\\s*>";
final String string = "\n"
+ "<div id=\"page126-div\" style=\"position:relative;width:918px;height:1188px;\">\n"
+ "</div>\n\n"
+ "<div id=\"page127-div\" style=\"position:relative;width:918px;height:1188px;\">\n"
+ "sometext for example\n"
+ "</div>\n\n"
+ "<div id=\"page128-div\" style=\"position:relative;width:918px;height:1188px;\">\n"
+ "</div>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}