$re = '/(?><div(?=(?:[^>"\']|"[^"]*"|\'[^\']*\')*?\sid\s*=\s*(?:([\'"])\s*page(?:(?!\1)[\S\s])*\1))\s+(?:"[\S\s]*?"|\'[\S\s]*?\'|(?:(?!\/>)[^>])?)+>)\s*[\S\s]{0,5}\s*<\/div\s*>/';
$str = '
<div id="page126-div" style="position:relative;width:918px;height:1188px;">
</div>
<div id="page127-div" style="position:relative;width:918px;height:1188px;">
sometext for example
</div>
<div id="page128-div" style="position:relative;width:918px;height:1188px;">
</div>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);