# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^\s]+)\s+((?1)\s+(?1))/\1 \2,/gm;t' <<< "Some example here for you"