// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^\s]+)\s+((?1)\s+(?1))").unwrap();
let string = "Some example here for you";
let substitution = "\\1 \\2,";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}