#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[A-Z]+(?:_[A-Z]+)*(?:\n[A-Z]+(?:_[A-Z]+)*)*$"
Local $sString = "ERIS_TEST_GROUP_NAME" & @CRLF & _
"JENNIFER_AD_GROUP_NAME" & @CRLF & _
"PSEUDO_TEST_TEAM" & @CRLF & _
"TEST_GROUP"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")