package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^[a-zA-Z_][-_a-zA-Z0-9]){0,39}$`)
var str = `Word`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}