# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\{.+\"from\":\"(\d+)\".+\"checkId\":\"(\d+)\".+\"keyword\":\"([a-zA-Z]+)\".+\}"
test_str = "{\"transfId\":\"S0722182156164591494745777M\",\"messageId\":\"123\",\"from\":\"5777\",\"to\":\"59395436474\",\"status\":-1,\"checkId\":\"1975\",\"price\":0,\"keyword\":\"OK\",\"errorCode\":601,\"errorMessage\":\"SUCCESS\",\"date\":\"20150730 09:00:00\",\"model\":\"wer_tr\"}"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.