const regex = /\[(if)\s+([^\]]*+)\]
((?>[^[]++(?:\[(?!(?:end)?if\b)[^[]*)*|(?R))*)
\[endif\]/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(if)\\s+([^\\]]*+)\\]
((?>[^[]++(?:\\[(?!(?:end)?if\\b)[^[]*)*|(?R))*)
\\[endif\\]', 's')
const str = `[if coooondition1] aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa [if condaition2] baab [endif] [endif]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}