using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)<img[^>]+? src\s*?=\s*?""(.*?\?contextId.*?)""[^\/]+?\/>";
string input = @"<img xmlns=""http://www.w3.org/1999/xhtml"" src=""http://10.206.38.34:8080/resource/resources/aktuelle_Ressourcen/eService/Bilder/uebersicht-router.png?contextId=eservice_1.0.0.qualifier"" alt=""Bild Übersicht Router"" title=""Übersicht Router"" />
<p> sdfs </p>
<img xmlns=""http://www.w3.org/1999/xhtml"" src=""http://localhost:8080/resource/carl/eService/rain/apple.png?contextId=eservice_aaa"" alt=""Communicator"" title=""Super Robot"" />
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}