$re = '/[\s\'](\w+)\-(\w+)/';
$str = 'SELECT some-name, some-name FROM [some-name] WHERE [some-name] = \'some-name\'
';
$subst = "\1 - \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;