package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?(https?:\/\/\S*\.jpg).*`)
var str = `background-color:#000000; background-image:url(https://www.sample.com/free-videos/player-images/20170204-01.jpg); background-size: cover; position: relative;`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}