import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:copyright[ \\t]*)?(?:©|\\(c\\)|&#(?:169|xa9;)|©)[ \\t]+(?:19|20)[0-9]{2} Company(?: All Rights Reserved)?";
final String string = "Copyright © 2019 Company All Rights Reserved\n"
+ "© 2019 Company All Rights Reserved\n"
+ "© 2019 Company\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}