$re = '/(?:copyright[ \t]*)?(?:©|\(c\)|&#(?:169|xa9;)|©)[ \t]+(?:19|20)[0-9]{2} Company(?: All Rights Reserved)?/mi';
$str = 'Copyright © 2019 Company All Rights Reserved
© 2019 Company All Rights Reserved
© 2019 Company
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);