using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https://(?:demo|test)\.site1\.mybrand\.company/\S*$";
string input = @"https://demo.site1.mybrand.company/
https://test.site1.mybrand.company/
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}