#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)image(\d\d)$"
Local $sString = "image1" & @CRLF & _
"image2" & @CRLF & _
"image3" & @CRLF & _
"image4" & @CRLF & _
"image5" & @CRLF & _
"image6" & @CRLF & _
"image7" & @CRLF & _
"image8" & @CRLF & _
"image9" & @CRLF & _
"image10" & @CRLF & _
"image11" & @CRLF & _
"image12" & @CRLF & _
"image13" & @CRLF & _
"image14" & @CRLF & _
"image15" & @CRLF & _
"image100" & @CRLF & _
"image101" & @CRLF & _
"image102" & @CRLF & _
"image103" & @CRLF & _
"image104" & @CRLF & _
"image105"
Local $sSubst = "image0$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)