import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "image(\\d\\d)$";
final String string = "image1\n"
+ "image2\n"
+ "image3\n"
+ "image4\n"
+ "image5\n"
+ "image6\n"
+ "image7\n"
+ "image8\n"
+ "image9\n"
+ "image10\n"
+ "image11\n"
+ "image12\n"
+ "image13\n"
+ "image14\n"
+ "image15\n"
+ "image100\n"
+ "image101\n"
+ "image102\n"
+ "image103\n"
+ "image104\n"
+ "image105";
final String subst = "image0$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}