re = /^.*stuff382689,\d+$/m
str = '/category/stuff382689,25090
/category/stuff382689,25090,,1
/category/stuff382689,25090,,2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end