$re = '/(Failed to handle request ).+( on subject.*)/';
$str = 'Failed to handle request 0[null->null s:0 w:0.0 a: 0.0 S:0 t: 24543060 s(NA) (0 0)] on subject RealTimeUpdate
Failed to handle request blablabla on subject RealTimeUpdate
Failed to handle request test0120120120 on subject RealTimeUpdate';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);