#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?!\B"[^"]*),(?![^"]*"\B)"
Local $sString = "bob jones,123,55.6,,,"Hello , World",,0" & @CRLF & _
"jim neighbor,432,66.5,,,Andy "Blank,,1" & @CRLF & _
"john smith,555,77.4,,,Some value,,2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")