$re = '/(([A-Za-z0-9]+\w*[\.\-]?){1,}+\w*@([A-Za-z0-9]+\.){1,2}[A-z]{2,3})/';
$str = 'this.is.a.test@foo.bar.com
pie@fizzbuzz.be
_pie_underscore-hyphen-@lamepun.us
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);