re = /(([A-Za-z0-9]+\w*[\.\-]?){1,}+\w*@([A-Za-z0-9]+\.){1,2}[A-z]{2,3})/
str = 'this.is.a.test@foo.bar.com
pie@fizzbuzz.be
_pie_underscore-hyphen-@lamepun.us
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end