package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bstop.*\b`)
var str = `stop
hey stop select random
not the start of line stopping but the end
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}