#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)^stop.*"
Local $sString = "stop" & @CRLF & _
"stopping with line" & @CRLF & _
"stop and so on" & @CRLF & _
"hey stop select random" & @CRLF & _
"not the start of line stopping but the end" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")