using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^stop.*";
string input = @"stop
stopping with line
stop and so on
hey stop select random
not the start of line stopping but the end
";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}