const regex = /^((?:\+27|27)|0)(\d{9})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:\\+27|27)|0)(\\d{9})$', '')
const str = `08277 11380`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}