using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^N;|[bdi]:[0-9.E-]+;|s:[0-9]+:"".*"";|a:[0-9]+:{.*}|O:[0-9]+:""[A-Za-z0-9_\\]+"":[0-9]+:{.*}$";
string input = @"N;
b:0;
b:1;
i:0;
i:1;
i:-1;
d:0;
d:1;
d:-1;
d:-1.2;
s:0:"";
s:3:""foo"";
a:0:{}
a:6:{i:0;N;i:1;b:0;i:2;i:0;i:3;d:0;i:4;s:2:""''"";s:3:""foo"";s:5:""bar"";}
O:8:""stdClass"":0:{}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}