const regex = /^N;|[bdi]:[0-9.E-]+;|s:[0-9]+:".*";|a:[0-9]+:{.*}|O:[0-9]+:"[A-Za-z0-9_\\]+":[0-9]+:{.*}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^N;|[bdi]:[0-9.E-]+;|s:[0-9]+:".*";|a:[0-9]+:{.*}|O:[0-9]+:"[A-Za-z0-9_\\\\]+":[0-9]+:{.*}$', 'gm')
const str = `N;
b:0;
b:1;
i:0;
i:1;
i:-1;
d:0;
d:1;
d:-1;
d:-1.2;
s:0:"";
s:3:"foo";
a:0:{}
a:6:{i:0;N;i:1;b:0;i:2;i:0;i:3;d:0;i:4;s:2:"''";s:3:"foo";s:5:""bar"";}
O:8:"stdClass":0:{}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}