$re = '/^N;|[bdi]:[0-9.E-]+;|s:[0-9]+:".*";|a:[0-9]+:{.*}|O:[0-9]+:"[A-Za-z0-9_\\\\]+":[0-9]+:{.*}$/m';
$str = 'N;
b:0;
b:1;
i:0;
i:1;
i:-1;
d:0;
d:1;
d:-1;
d:-1.2;
s:0:"";
s:3:"foo";
a:0:{}
a:6:{i:0;N;i:1;b:0;i:2;i:0;i:3;d:0;i:4;s:2:"\'\'";s:3:"foo";s:5:""bar"";}
O:8:"stdClass":0:{}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);