$re = '/(?<=@)\w+/m';
$str = 'message = <<-MESSAGE
From @victor with love,
To @andrea,
and CC goes to @ghost
MESSAGE';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;