#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)[0-9]+[\r\n]+.*[\r\n]+S0B0L"
Local $sString = "39983" & @CRLF & _
""set x 1"" & @CRLF & _
"random_user" & @CRLF & _
"" & @CRLF & _
"39984" & @CRLF & _
""set x 45"" & @CRLF & _
"S0B0L" & @CRLF & _
"" & @CRLF & _
"39985" & @CRLF & _
""set x 23"" & @CRLF & _
"random_user"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")