import re
regex = re.compile(r"(?i)[0-9]+[\r\n]+.*[\r\n]+S0B0L")
test_str = ("39983\n"
"\"set x 1\"\n"
"random_user\n\n"
"39984\n"
"\"set x 45\"\n"
"S0B0L\n\n"
"39985\n"
"\"set x 23\"\n"
"random_user")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")