// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)[0-9]+[\r\n]+.*[\r\n]+S0B0L").unwrap();
let string = "39983
\"set x 1\"
random_user
39984
\"set x 45\"
S0B0L
39985
\"set x 23\"
random_user";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}