#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "("model.*\{.*(\n.*)+?\n.+\},)"
Local $sString = "{" & @CRLF & _
" "model": {" & @CRLF & _
" "template": "model.txt"," & @CRLF & _
" "directory": "app/models"," & @CRLF & _
" "filename": "{{Entity}}.php"" & @CRLF & _
" "moar": "moar.php"" & @CRLF & _
" }," & @CRLF & _
"{" & @CRLF & _
" "other": {" & @CRLF & _
" "template": "model.txt"," & @CRLF & _
" "directory": "app/models"," & @CRLF & _
" "filename": "{{Entity}}.php"" & @CRLF & _
" },"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")