const regex = /("model.*\{.*(\n.*)+?\n.+\},)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('("model.*\\{.*(\\n.*)+?\\n.+\\},)', 'g')
const str = `{
"model": {
"template": "model.txt",
"directory": "app/models",
"filename": "{{Entity}}.php"
"moar": "moar.php"
},
{
"other": {
"template": "model.txt",
"directory": "app/models",
"filename": "{{Entity}}.php"
},`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}