$re = '/("model.*\{.*(\n.*)+?\n.+\},)/';
$str = '{
"model": {
"template": "model.txt",
"directory": "app/models",
"filename": "{{Entity}}.php"
"moar": "moar.php"
},
{
"other": {
"template": "model.txt",
"directory": "app/models",
"filename": "{{Entity}}.php"
},';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);