$re = '/(~(?(?=.*?~~.*?~).*?~.*?~.*?~|[^~]+?~))/';
$str = '~The ~spectacle~~ was ~borken~, but that was not the same ~spectacle~
that was given to ~me~.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);