re = /^(http(s)??\:\/\/)?(www\.)?((youtube\.com\/watch\?v=)|(youtu.be\/))([a-zA-Z0-9\-_])+$/
str = 'https://www.youtube.com/watch?v=
https://www.youtube.com/watch?v='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end