using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ATC02007([0-9]{14})(_UFF_ACC)?.xls$";
string substitution = @"$1";
string input = @"ATC0200720140828080610.xls
ATC0200720140901080346_UFF_ACC.xls";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}