const regex = /^ATC02007([0-9]{14})(_UFF_ACC)?.xls$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ATC02007([0-9]{14})(_UFF_ACC)?.xls$', 'gm')
const str = `ATC0200720140828080610.xls
ATC0200720140901080346_UFF_ACC.xls`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);