use strict;
my $str = 'ATC0200720140828080610.xls
ATC0200720140901080346_UFF_ACC.xls';
my $regex = qr/^ATC02007([0-9]{14})(_UFF_ACC)?.xls$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";