#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "/\*(?:(?!\*/|/\*).)*\R(?s).*?\*/"
Local $sString = "/* comment */ not a comment /* another comment */" & @CRLF & _
"" & @CRLF & _
"/* delete this *" & @CRLF & _
"/* multiline *" & @CRLF & _
"/* comment */" & @CRLF & _
"" & @CRLF & _
"/*************" & @CRLF & _
"/* and this * " & @CRLF & _
"/************/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")