package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{2})(\d{2})(?P<MM>\d{2})(?P<DD>\d{2})(?P<HH>\d{2})(?P<mm>\d{2})(?P<ss>\d{2})\.(?P<SSSSSS>\d{6})(?P<ZZ>[-+]\d{3,4})$`)
var str = `20201222152131.000000+120
to
12/22/20 15:21:31`
var substitution = "$1/$2/$3 $4:$5:$6"
fmt.Println(re.ReplaceAllString(str, substitution))
}