import Foundation
let pattern = #"^(\d{2})(\d{2})(?P<MM>\d{2})(?P<DD>\d{2})(?P<HH>\d{2})(?P<mm>\d{2})(?P<ss>\d{2})\.(?P<SSSSSS>\d{6})(?P<ZZ>[-+]\d{3,4})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
20201222152131.000000+120
to
12/22/20 15:21:31
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1/$2/$3 $4:$5:$6"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)